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1 What is FTP?

FTP stands for File Transfer Protocol, which is the standard Internet protocol for the transfer of files.
There are many programs that use FTP to upload files to the Internet. Included in this guide are
directions to using several of the most popular programs for both Macs and PCs to upload your files to

directNIC's servers.
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2 Important Tips

2.1 Home Directory vs. Domain Directory

All domains hosted by directNIC in a specific account use the same username and password when
accessing the server via FTP. This is because for each account there is one Home Directory on the
hosting server. Each hosted domain and virtualhost has an individual Domain Directory within the
Home Directory for the account. FTP programs will log the user into the Home Directory unless you
specify otherwise. When in the Home Directory, all the Domain Directories are listed and usually
accessible simply by clicking on them. Whenever uploading files, make certain they are being uploaded
to the Domain Directory and not the Home Directory.

2.2 Default Page

The default page for your site must be named index.html or index.htm, all in lower case.

2.3 Firewall

If a computer is behind a firewall, connecting via FTP may require adjusting certain settings on your
FTP program. Though these settings may be found in different areas of the program, generally the way
to connect via FTP from behind a firewall is to set the program to Active mode. In addition, many
programs have an option to Enable Firewall Access.
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3 Using Common FTP Programs

Step-by-step instructions with screenshots (images) are available at
http://www.directnic.com/reference/index.php

3.1 CUTEFTP

Trial version can be downloaded at: http://www.download.com/3000-2160-10000625.html
Screenshot illustrations are available at http://www.directnic.com/reference/index.php ?topic=cuteftp

Choose Site Manager from the File menu. Choose which folder you would like the Site Profile to be in
(possibly in the General FTP Sites folder) and click on the New button. Next fill in the following fields:

Label: Whatever you want to name the site profile

FTP Host Address: yourdomainname.com

FTP Home Directory: yourdomainname.com

FTP site User Name: Your directNIC username

FTP site Password: Your directNIC password

FTP site Port Connection: 21

Set the Login Type to Normal

Then click on Connect.

Once you are logged in, the left window is the Local Window and the right window is the Remote
Window. In the Remote Window, you will be logged into the Home Directory; open up the Domain
Directory to which you want to upload your site. Then, choose the files in the Local Window you want to

upload and click and drag them to the Remote Window.

The next time you need to upload to that site, simply choose Site Manager from the File menu and
click on the Site Profile and click Connect.

If you are behind a firewall, you may need change the settings. Choose Settings from the Edit menu.

Double click on Connection and then click on Firewall. Check the Enable Firewall Access and
Active mode boxes. This should allow you to upload from behind a firewall.

3.2 WS_FTP

Trial version can be downloaded at: http://www.ipswitch.com/

Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=wsftp
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Upon opening WS_FTP the Session Properties window will pop up. If you have entered the
information prior to this session, simply choose the Profile Name of the site you wish to use. If you
have not already entered the site you are uploading to, click the New button to clear the fields and then
enter the following:
Profile Name: Enter your domain name here (yourdomainname.com)
Host Name/Address: Enter your domain name here (yourdomainname.com)
Host Type: Automatic Detection
User ID: Your directNIC username
Password: Your directNIC password
If you are located behind a firewall or gateway, you may need to alter the settings to allow for Active
transfers. To do this, click on the Advanced tab and check the box next to Active Transfer or make
sure the Passive FTP is turnd OFF.
Next, click OK to log in.
The window on the left is the local listing and the window on the right is the remote listing. To upload

files, simply highlight the files to transfer and either click and drag them from the local to the remote
window or click the arrow button between the windows.

3.3 DREAMWEAVER

http://macromedia.com/software/dreamweaver/

Screenshot illustrations are available at
http://www.directnic.com/reference/index.php?topic=dreamweaver

When starting a new site, simply go to the Site pull-down menu and choose New Site. If resetting the
FTP information on an existing site, choose Define Sites from the same pull-down menu and click on
the site you wish to set up.

Choose Remote Info from the Category list and in the pull-down Access Menu choose FTP. Then fill
in the following fields as such:

FTP Host: yourdomainname.com

Host Directory: yourdomainname.com

Login: your directNIC username

Password: your directNIC password

When you want to upload your site, simply choose the Connect to Remote Host icon (it looks like 2

wires plugged together) on the toolbar of the Site Window. Then, copy your files from the Local Folder
to the Remote Site.
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http://macromedia.com/software/dreamweaver

Uploading Using FTP

Make sure you have the Passive FTP option turned off on your connection.

3.4 FRONTPAGE 98 & 2000

Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=frontpage

From the File Menu choose Publish Web. In the field: Specify the location to publish you web
to:ftp://yourdomainname.com/yourdomainname.com

Note:You do not want to enter the www on your domain name address.

Then click Publish

Next fill in the fields:

Name: Your directNIC username

Password: Your directNIC password

Then click OK

When the site is finished uploading, simply click Done.

Note for uploading a site for the first time: If the default page for your web is called "index.htm" the
following question will be prompted: The file index.html exists on the destination server but does not
exist in the current Web. Would you like Frontpage to remove it? Click on the Yes button. This is
because our default under construction page is called index.html and our servers look for index.html file
before an index.htm file and if both are on the server our under construction page will still show for your

site.

Remember that directNIC hosting servers do not support Front Page Extensions, so you will want to
turn off this feature for your program when designing for your DN hosted sites.

3.5 CUPERTINO

http://www.winsite.com/bin/Info?500000024059

Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=cupertino
Using Cupertino is great if you have many different sites you want to keep login information stored for:
From the File menu choose New FTP Site or click on the small computer icon. First uncheck the Use
Anonymous Login to open up the username and password fields. For the Label field, you can use
whatever you want; this is simply to reference the site in Cupertino. For the other fields:

Host Address: yourdomainname.com

Home Directory: yourdomainname.com

User ID: Your directNIC username
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Password: Your directNIC password
Port: 21

Login Directory: yourdomainname.com
Then click OK to save the information.

To log in, simply double click the Site Label you want to log into in the left window. Any folders or files
you have in that directory will appear in the right window.

Now at the top of the left window are your local drives. Find the folder for the files you wish to upload
and double click on that. Now all the folders and files will appear in the right window. Choose the

folders and files you wish to upload from the right window, and click and drag them to the Site Label in
the left window to which you are uploading.

3.6 FTP VOYAGER

http://www.ftpvoyager.com

Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=voyager
Click on Connect Icon and the FTP Site Profile Manager will pop up.

Next click New Site and, in the fields to the right of the manager, fill in the following information:
Name: Use whatever you want; this is simply to reference the site in FTP Voyager
Description: Again, simply used as a reference in FTP Voyager you can even leave it blank
FTP Site: yourdomainname.com

Default Directory: yourdomainname.com

Make sure the Anonymous Login is unchecked

User ID: Your directNIC username

Password: Your directNIC password

Then click Connect.

Once connected, simply click and drag the files from the Local (bottom) Window to the Remote (top)
Window.

Note: Once you have created a site in the FTP Site Profile Manager, the next time you want to upload

to it simply click Connect Icon and in the manager double click on the site with which you need to
connect.
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3.7 Netscape 3.x-4.x

http://www.netscape.com

Using Netscape to upload is pretty simple. In the address bar type
ftp://username:Password@yourdomainname.com This will log you into the Home Directory. From here,
click on the Domain Directory to which you want to upload. Once in the Domain Directory, you can
upload either by clicking and dragging the files from a folder on your computer into the Domain
Directory, or by going to the File pull down menu and choosing Upload File. Choose the files you wish
to upload and click on Open.

* At this time there is no upload feature on Netscape 6.x

3.8 Internet Explorer

http://www.microsoft.com
Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=ie

Using Internet Explorer 7 to upload is easy. In the address bar type ftp://yourdomainname.com You
may see an error message which says something like this: Internet Explorer cannot display the
webpage.

That is OK. Find a Page menu and choose Open FTP site in Windows Explorer. Then you will be
prompted to enter your username and password. Then you will see your domain directory.

Sometimes you might see an error messages which says something like: Windows cannot access this
folder.

This error doesn't matter & it's just telling you that you'll need a password. Click OK.
In the File menu select Login As...

Enter your direcNIC login. This will log you into the Home Directory. Click the Folders button in the
toolbar. This allows you to see your local files on the left and the FTP server files on the right. From
here open the folder for the server Domain Directory to which you want to upload. You are now ready to
begin transferring files. You can right-click files and select Copy to Folder, or simply drag and drop files
between your local drives and the FTP server.

Note: You must have the Passive FTP option turned off to use this FTP connection. Here's how to
de-activate this feature:

Click on Tools

Click on Internet Options

Click on Advanced Tab

Uncheck the "Use Passive FTP" feature.

The following instructions apply to lower version IE: In the address bar type
ftp://username:Password@yourdomainname.com This will log you into the Home Directory. From here
open the folder for the Domain Directory to which you want to upload. Once in the Domain Directory,
simply click and drag the files from your computer into the Domain Directory.
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Note: You must have the Passive FTP option turned off to use this FTP connection. Here's how to
de-activate this feature:

Click on Tools

Click on Internet Options

Click on Advanced Tab

Uncheck the "Use Passive FTP" feature.

3.9 FileZilla

http://filezilla.sourceforge.net/

Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=filezilla
Once FileZilla has started, enter the following details in the fields at the top of the program window.
Address: yourdomain.com

User: Your directNIC username

Password: Your direcfNIC password

Port: 21

Click Quickconnect to connect to your site.

From now on you will be able to select this site and other recent sites from the Quickconnect history
drop menu.

If you have many sites and would like to add it to your Site Manager, you can select "Copy
connection to Site Manager" from the "File" menu once connected.

Highlight New FTP Site and click Rename, and then name the connection something you will
recognize, the domain name, for instance.

Click Save and Exit.

You will now be able to connect to the site at any time using the Site Manager drop down menu, or by
clicking the site manager icon.

NOTE: Passive mode should be turned off by default, but if you experience problems transferring files
once a connection is successful, you may want to double check its status:

1. Select Settings from the "Edit" menu.
2. Select Firewall settings from the left hand menu.

3. Find the Passive Mode check box in the main window. It should not have a check mark next to it, if
there is, click on the box to un-check this option.

4. Click OK.
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3.10 FireFTP
FireFTP
https://addons.mozilla.org/en-US/firefox/addon/684
Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=fireftp

Note: The default homepage page (first page) for your site must be named index.html or index.htm,
all in lower case.

An example domain name and user name were used through the instructions. Please substitute your
own directNIC domain name and login information for the account used in the instructions.

Uploading Steps:

1. Open FireFTP by going to the Tools menu in the Firefox toolbar. Choose FireFTP from the
dropdown menu.

2. Once FireFTP opens, click on Manage Accounts left of the screen. Choose New from the drop
down menu.

3. Enter the following information in the Account Manager window that pops up:
Account Name: The name you would like to keep this FTP profile as.

Host: Enter your domain name here (yourdomainname.com)

Login: Your directNIC username

Password: Your directNIC password

Click OK to save your information and close the pop up window.

4. When the Account Manager window closes, click Connect on the top left of the screen, next to the
drop-down menu that has the Account Name you have give this account.

5. The frame on the left is the local listing and the frame on the right is the remote listing. To upload
files, simply highlight the files to transfer and either click and drag them from the local to the remote
frame or click the arrow button between the frames.

Note: Once you have created a site in FireFTP, the next time you want to upload to it simply select the
site profile name from the drop down menu next to Manage Accounts and then click Connect.

3.10 FireFTP
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4 MACINTOSH
4.1 FETCH

http://www.fetchsoftworks.com

Screenshot illustrations are available at http://www.directnic.com/reference/index.php?topic=fetch
Fill in the fields with the following information:

Host: yourdomainname.com

User ID: Your directNIC username

Password: Your directNIC password

Directory: yourdomainname.com

Then click OK and you're logged in.

Once you're logged in, you can upload by clicking and dragging files from the desktop or any open
folders into the Fetch Window; or, using the "Put File" button.

4.2 ANARCHIE

After launching Anarchie choose Get from the File menu. In the following window fill in the following
fields:

Server: yourdomainname.com

Path: yourdomainname.com
Username: Your directNIC username
Password: Your directNIC password

Then click on List or click Save first to save your settings for future use. Once you're logged in you can
click and drag files from the desktop or any open folders into the Anarchie Window.

4.3 TRANSMIT

http://www.panic.com/transmit/index.html
Upon launching Transmit fill in the following fields:
Address: yourdomainname.com

Username: Your directNIC username
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Password: Your directNIC password
Directory: yourdomainname.com
Then click on Connect.
Once you have logged in, the window will be split in two; the left being the Local Window, and the right
being the Remote Window. To upload your files, simply double click or click and drag the files from the

Local Folder across to the Remote Folder or even click and drag files from the desktop or any open
folders.

4.3 TRANSMIT 11
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